Login | Register 
FEATURES
APPLICATIONS
DOWNLOADS
EDUCATION
BLOG
WIKI
FORUM
STORE

Very poor GPU performance all of a sudden

General discussion about anything TouchDesigner

Very poor GPU performance all of a sudden

Postby b34npour » Thu Jun 23, 2016 9:45 pm

A few days ago I noticed that when I opened up TouchDesigner to the default "flower noise" network my frame rate had dropped to 30fps. Initially I thought that maybe my monitor had been accidentally set to 30Hz, but that wasn't the issue.

So I opened up the Performance Monitor and noticed that my GPU operations are taking an extremely long time (see attached screenshot). It looks like two gfx operations are the culprits:

- "Uploading a 2D texture" is taking a whopping 13ms and appears to be related to the chopto1 TOP

- "Flushing GPU Commands and Changing Graphics Content" also takes nearly 13ms

Has anyone experienced this issue? I have a Nvidia GTX 980 Ti and tried updating the graphics driver but it didn't have any effect. The only thing I can think of that I installed around the time this problem arose is that I installed CUDA 7.5 for Octane Render, but I'm not sure how that would affect Touch.

Thanks!
Attachments
perfmon.jpg
perfmon.jpg (271.76 KiB) Viewed 4136 times
b34npour
 
Posts: 19
Joined: Wed Jan 09, 2013 8:01 pm

Re: Very poor GPU performance all of a sudden

Postby emintzer » Thu Jun 23, 2016 11:44 pm

I would say to triple check you have the newest NVidia driver, but here are some other maybe obvious things to check.

- Did you accidentally plug your monitor in to your motherboard?
- Do you have other GPU-intensive programs running simultaneously?
- Also, I think? that those performance operations are actually an exchange of information from your cpu to your gpu, so if your cpu is oddly bottlenecked that can also cause this slow down?
emintzer
 
Posts: 166
Joined: Thu Aug 30, 2012 11:30 am

Re: Very poor GPU performance all of a sudden

Postby b34npour » Fri Jun 24, 2016 12:34 am

emintzer wrote:I would say to triple check you have the newest NVidia driver, but here are some other maybe obvious things to check.

- Did you accidentally plug your monitor in to your motherboard?
- Do you have other GPU-intensive programs running simultaneously?
- Also, I think? that those performance operations are actually an exchange of information from your cpu to your gpu, so if your cpu is oddly bottlenecked that can also cause this slow down?


Hi Emintzer, I've been pretty diligent with my tests, so I know that there aren't any other processes running that could be hogging the GPU. Also double checked that I have the latest drivers today.

Interesting point about those operations actually being exchange between the CPU and GPU, I'll double check to see if there's anything weird happening in the background with my CPU.

Thanks for the notes!
b34npour
 
Posts: 19
Joined: Wed Jan 09, 2013 8:01 pm

Re: Very poor GPU performance all of a sudden

Postby elburz » Fri Jun 24, 2016 4:14 am

Have you tried putting it in perform mode full screen at 60fps and monitoring the fps only from perform mode (without performance monitor window open)?
--
Elburz Sorkhabi
Creative + Technology
nVoid Art-Tech Limited
http://nvoid.com
elburz
 
Posts: 2011
Joined: Fri Jun 01, 2012 6:55 pm
Location: Toronto, Canada

Re: Very poor GPU performance all of a sudden

Postby b34npour » Fri Jun 24, 2016 10:22 am

Hi Elburz, yep, I was thinking the same thing. I tried hooking a Perform CHOP to a Trail CHOP, then going into perform mode for a bit, then going back to check the FPS over time. It never goes above 30fps.
b34npour
 
Posts: 19
Joined: Wed Jan 09, 2013 8:01 pm

Re: Very poor GPU performance all of a sudden

Postby elburz » Fri Jun 24, 2016 11:22 am

Another method that's pretty reliable is to use the cook channel from perform chop, it tells you if you lose a frame cook. If you put a slight lag on that, you can connect it to the opacity of a constant top, then just composite it on your output, then you can be in perform mode, not worry about trails cooking, and can visually see if you're dropping a frame if your constant top is flickering.

unfortunately not quite sure what it could be. did anything change recently?
--
Elburz Sorkhabi
Creative + Technology
nVoid Art-Tech Limited
http://nvoid.com
elburz
 
Posts: 2011
Joined: Fri Jun 01, 2012 6:55 pm
Location: Toronto, Canada

Re: Very poor GPU performance all of a sudden

Postby b34npour » Sun Jun 26, 2016 1:07 am

elburz wrote:Another method that's pretty reliable is to use the cook channel from perform chop, it tells you if you lose a frame cook. If you put a slight lag on that, you can connect it to the opacity of a constant top, then just composite it on your output, then you can be in perform mode, not worry about trails cooking, and can visually see if you're dropping a frame if your constant top is flickering.

unfortunately not quite sure what it could be. did anything change recently?


That's awesome, I've never heard of that method of checking frames.

Nothing has changed yet. I'm about to reinstall my OS to see if it's a hardware issue haha, will report...
b34npour
 
Posts: 19
Joined: Wed Jan 09, 2013 8:01 pm

Re: Very poor GPU performance all of a sudden

Postby kv » Sat Jun 23, 2018 3:16 pm

Hello
I'm having the same issue that the fps doesn't go beyond 30fps.
Have checked on all the suggestion give above.
Requesting for help.

Thanks
kv
 
Posts: 1
Joined: Thu Jun 07, 2018 7:00 am

Re: Very poor GPU performance all of a sudden

Postby ben » Mon Jun 25, 2018 1:44 pm

Could you try Perform Mode and on the Window COMP change the Vsync parameter to 'disabled'. I am wondering if vsync is doing strange stuff and capping you guys at 30fps. (Or you can change the setting globally in Nvidia Control Panel). We are seeing a lot of vsync problems with Optimus laptops lately over the past few Windows Updates.
User avatar
ben
Staff
 
Posts: 2374
Joined: Thu Nov 08, 2007 6:55 pm
Location: Toronto

Re: Very poor GPU performance all of a sudden

Postby leroy_lights » Tue Jun 26, 2018 6:16 am

I've had this bug combined with additional really heavy frame drops whenever I would open a second window.If you haven't already try to uninstall the Nvidia Geforce Experience software. It seems that it causes quite a lot of problems with TD099.

Hope that helps!

David
leroy_lights
 
Posts: 8
Joined: Tue Nov 17, 2015 8:55 am

Next

Return to General TouchDesigner Discussion

Who is online

Users browsing this forum: No registered users and 15 guests