Login | Register 
FEATURES
APPLICATIONS
DOWNLOADS
EDUCATION
BLOG
WIKI
FORUM
STORE

FIXED: NDI In Top not working on High Bandwidth setting?

Report bugs so we can squash them!

FIXED: NDI In Top not working on High Bandwidth setting?

Postby desn.joshmichael » Fri Feb 15, 2019 3:57 pm

Hi,

Im trying to use the NDI In TOP and for some reason it only works on Low Bandwidth mode. Is this a common issue?
Manually setting the Search IP also yields no results.

TD 2018.25850
BirdDog Ndi device

Thanks very much!
desn.joshmichael
 
Posts: 11
Joined: Wed Oct 26, 2016 3:36 pm

Re: NDI In Top not working on High Bandwidth setting?

Postby nettoyeur » Fri Feb 15, 2019 4:32 pm

You're running an older version of TD - can you try updating to the current official release?
NDI got some updates in recent versions of TD.
Idzard Kwadijk | freelance TouchDesigner consultant | IdzArd.com
Checkout ChopChopChop.org - the TouchDesigner marketplace!
nettoyeur
 
Posts: 1176
Joined: Mon Oct 15, 2012 12:00 pm
Location: Amsterdam, The Netherlands

Re: NDI In Top not working on High Bandwidth setting?

Postby desn.joshmichael » Fri Feb 15, 2019 4:35 pm

I can confirm its also an issue in the latest commercial official build as well.
desn.joshmichael
 
Posts: 11
Joined: Wed Oct 26, 2016 3:36 pm

Re: NDI In Top not working on High Bandwidth setting?

Postby ben » Sat Feb 16, 2019 8:18 pm

Moved to bugs forum, we’ll look into it.
User avatar
ben
Staff
 
Posts: 2599
Joined: Thu Nov 08, 2007 6:55 pm
Location: Toronto

Re: NDI In Top not working on High Bandwidth setting?

Postby desn.joshmichael » Sun Feb 17, 2019 6:29 pm

Amazing Ben! Thanks
desn.joshmichael
 
Posts: 11
Joined: Wed Oct 26, 2016 3:36 pm

Re: NDI In Top not working on High Bandwidth setting?

Postby Croolick » Mon Feb 18, 2019 2:02 pm

I think it doesn't work only for interlaced sources. I've checked many resolutions and framerates and NDI In TOP is working perfectly with progressive formats. So there must be a bug in ndi receive code - NDIlib_video_framev2_t structure has property named "allow_video_fields"...
Croolick
 
Posts: 2
Joined: Sun Jan 03, 2016 3:41 pm

Re: NDI In Top not working on High Bandwidth setting?

Postby malcolm » Mon Feb 25, 2019 1:48 pm

We specifically have that set to false right now, so NDI should be only providing use with progressive frames and doing the de-interlacing for us.
User avatar
malcolm
Staff
 
Posts: 4425
Joined: Tue Nov 13, 2007 1:11 am

Re: NDI In Top not working on High Bandwidth setting?

Postby benjamin.poels@vrt.be » Sat Aug 10, 2019 11:33 am

Sorry for using an old thread, but this still seems to be an issue when using interlaced NDI sources. Any chance this could be fixed?

Version: [2019.18360 ; Win64]
Steps to reproduce
*Select interlaced NDI input
-->Video is not shown, but audio is received
*Select Low bandwidth option
-->Video (and audio) is received (much lower quality)
benjamin.poels@vrt.be
 
Posts: 2
Joined: Sun Jun 23, 2019 3:39 pm

Re: NDI In Top not working on High Bandwidth setting?

Postby benjamin.poels@vrt.be » Sun Aug 18, 2019 4:55 pm

When receiving an interlaced source, the info CHOP is indicating a growing number of received_frames that seems to correlate with the fps of the NDI source. Could the problem be that, unlike the MOVIE IN or VIDEO STREAM IN TOPs, there currently is no deinterlace option for the NDI IN TOP? If so, then could this option be added?
benjamin.poels@vrt.be
 
Posts: 2
Joined: Sun Jun 23, 2019 3:39 pm

Re: NDI In Top not working on High Bandwidth setting?

Postby malcolm » Thu Sep 12, 2019 5:14 pm

Thanks for the report and sorry for the delay in fixing this. This will be fixed in the next build we post. 2019.19030 or later
User avatar
malcolm
Staff
 
Posts: 4425
Joined: Tue Nov 13, 2007 1:11 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 8 guests